JavaFx+Maven+jdk8

 
 
 
Сообщения:5
Добрый вечер! При запуске сборки приложения в терминале через Maven (mvn clean install) получаю ошибки такого типа
[ERROR] /C:/Users/Arkadiy/IdeaProjects/ServiceGUI/src/main/java/webview/tools/WebEngineProvider.java:[19,19] cannot find symbol
  symbol:   class WebEngine
  location: class webview.tools.WebEngineProvider
[ERROR] /C:/Users/Arkadiy/IdeaProjects/ServiceGUI/src/main/java/executors/threads/MainInfoExecutor.java:[5,26] package javafx.application does not exist
[ERROR] /C:/Users/Arkadiy/IdeaProjects/ServiceGUI/src/main/java/executors/threads/MainInfoExecutor.java:[6,28] package javafx.scene.control does not exist
[ERROR] /C:/Users/Arkadiy/IdeaProjects/ServiceGUI/src/main/java/executors/threads/MainInfoExecutor.java:[15,13] cannot find symbol
  symbol:   class Button
  location: class executors.threads.MainInfoExecutor
[ERROR] /C:/Users/Arkadiy/IdeaProjects/ServiceGUI/src/main/java/executors/threads/MainInfoExecutor.java:[18,50] cannot find symbol
  symbol:   class Button
  location: class executors.threads.MainInfoExecutor

то есть по сути не видит компоненты FX, хотя насколько я знаю они входят в состав 1.8

мой pom.xml
<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>groupId</groupId>
    <artifactId>ServiceGUI</artifactId>
    <version>1.0-SNAPSHOT</version>
    <packaging>jar</packaging>
    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.1</version>
                <configuration>
                    <source>8</source>
                    <target>8</target>
                </configuration>
            </plugin>
            <plugin>
                <artifactId>maven-assembly-plugin</artifactId>
                <executions>
                    <execution>
                        <phase>package</phase>
                        <goals>
                            <goal>single</goal>
                        </goals>
                    </execution>
                </executions>
                <configuration>
                    <archive>
                        <manifest>
                            <mainClass>sample.Main</mainClass>
                        </manifest>
                    </archive>
                    <descriptorRefs>
                        <descriptorRef>jar-with-dependencies</descriptorRef>
                    </descriptorRefs>
                </configuration>
            </plugin>
        </plugins>
    </build>

    <dependencies>
        <!-- https://mvnrepository.com/artifact/com.google.code.gson/gson -->
        <dependency>
            <groupId>com.google.code.gson</groupId>
            <artifactId>gson</artifactId>
            <version>2.8.5</version>
        </dependency>
        <!-- https://mvnrepository.com/artifact/org.apache.commons/commons-lang3 -->
        <dependency>
            <groupId>org.apache.commons</groupId>
            <artifactId>commons-lang3</artifactId>
            <version>3.8.1</version>
        </dependency>
    </dependencies>
</project>


также странно то, что через мавеновский инструмент в идее сборка проходит без ошибок. но мне бы хотелось собирать вручную
где косяк?

PS. после каждой сборки через терминал в идее, запуск приложения выдает такую ошибку
Error: Could not find or load main class sample.Main
делаю ребилд проекта, и нормально запускается
тоже хотел бы узнать, что не так
Изменен:16 окт 2019 17:47
 
Модераторы:Нет
Сейчас эту тему просматривают:Нет