Требования к системе

 
 
 
Сообщения:285
Где-нибудь вообще сформулированы требования, под которыми должна работать система? Полазил на http://wiki.jtalks.org, кроме стека используемых технологий ни чего не нашел.

По ходу дела единственно, что понял, что требования по версии Java - 7. Можно еще по Tomcat'у минимальную версию указать.

В частности, интересует также какие браузеры должны корректно отображать веб-морду? Поддерживаем ли IE9 (8, 7, 6, ... )? От этого зависит, какие можно правила стилей применять, стоит ли костылить под старые браузеры, полифилить ли JS и пр.

"Любая техническая система должна быть идиотоустойчивой" (с) один из университетских преподов
Изменен:06 июн 2016 19:44
 
 
Сообщения:9807
Java7+, Tomcat8
Browsers: Chrome, FF, Opera12; Android (последний) браузер по умолчанию, iPad. В IE11 главное, чтоб только самое основное работало - просмотреть сообщение, ответить.
 
 
Сообщения:285
Это радует (последние браузеры). Может есть смысл в wiki это оформить?

"Любая техническая система должна быть идиотоустойчивой" (с) один из университетских преподов
 
 
Сообщения:9807
Да где-то было, че-то не могу найти. QA найдут, пришлют ссылку :)
 
 
Сообщения:285
Староверъ:
Java7+, Tomcat8
Browsers: Chrome, FF, Opera12; Android (последний) браузер по умолчанию, iPad. В IE11 главное, чтоб только самое основное работало - просмотреть сообщение, ответить.


Да, и еще надо требования к СУБД указать.

У меня, кстати, на MariaDB 10.0 вроде бы норм все крутится.

"Любая техническая система должна быть идиотоустойчивой" (с) один из университетских преподов
 
 
Сообщения:9807
MySQL, там есть еще скрипты sample-forum.sql - они только на MySQL запустятся.
 
Модераторы:Нет
Сейчас эту тему просматривают:Нет